Welcome, Guest
Username: Password: Remember me
General discussions, feature requests for CodeTyphon Project and discussions that don't fit in any of the other specific CodeTyphon forum categories.
  • Page:
  • 1

TOPIC:

uebutton in CT Lab version 7.70 10 months 1 week ago #16598

  • Javier
  • Javier's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thank you received: 0
Hi

I just installed CT Lab version 7.70 in Windows 10 and it looks like "uebutton" is missing or deprecated

Could you help me on it?


Thank you
Regards

 

Please Log in or Create an account to join the conversation.

uebutton in CT Lab version 7.70 10 months 1 week ago #16599

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 777
  • Thank you received: 76
Yes, 
pl_BGRAuecontrols package Removed from LAB CT ver 7.70.

Use components from other pl_BGRAxxxx packages.
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

uebutton in CT Lab version 7.70 3 months 1 week ago #17265

  • Alex
  • Alex's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 0
Hello, I have just updated to 7.8 and have this same issue. I have 4 year old project that a lot of work went for and it has a lot depending on pl_BGRAuecontrols , but now everything doesnt work because that was removed. Is there a way to add that package back manually?

Thanks!

Please Log in or Create an account to join the conversation.

uebutton in CT Lab version 7.70 3 months 6 days ago #17266

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 777
  • Thank you received: 76
You can copy pl_BGRAuecontrols from CT 7.0 to CT 7.80.
Install pkg and and rebuild Typhon IDE
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

uebutton in CT Lab version 7.70 3 months 6 days ago #17271

  • Alex
  • Alex's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 0
That is actually what I have been trying to do but so far was not successful. Anyway you could please assist with that? Thanks! 

Please Log in or Create an account to join the conversation.

uebutton in CT Lab version 7.70 3 months 6 days ago #17272

  • Alex
  • Alex's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 0
What I have done is copied pl_BGRAuecontrols folder into C:\codetyphon\typhon\components. I did go to New Package (under packaga), added pl_bgrauecontrols.ctpkg inside the copied pl_BGRAuecontrols folder. It asked to rebuild ide, I did that and when I go to build my app, I get:

mainunit.pas(9,59) Error: Cannot find uETileImage used by mainUnit, incompatible ppu=C:\codetyphon\typhon\components\pl_BGRAuecontrols\lib\x86_64-win64\win32\uetileimage.ppu, package pl_bgrauecontrols

Please Log in or Create an account to join the conversation.

Last edit: by Alex.

uebutton in CT Lab version 7.70 3 months 6 days ago #17273

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 777
  • Thank you received: 76
Close TyphonIDE
Copy pl_BGRAuecontrols to 
C:\codetyphon\typhon\components\packages_pl\
folder

Open TyphonIDE and Open pl_BGRAuecontrols pkg, NOT new pkg
-Build pl_BGRAuecontrols Pkg
-Install pl_BGRAuecontrols Pkg
-Rebuild TyphonIDE
 
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

Last edit: by Matis A..

uebutton in CT Lab version 7.70 3 months 3 days ago #17279

  • Jens
  • Jens's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
I did it another way. I wrote myself a converter to update my old projects. Replacements in ctpr, ppr, frm and pas files are necessary. Since I used only "TuELED" from BGRAuecontrols in the past, its not a big thing. The biggest advantage for me is, there is no need to install old packages in new CT versions.

What I did:
  • replace all "pl_BGRAuecontrols" with "pl_BGRAextra" in all .ppr and .ctpr files 
  • replace all "TuELED" with "TbgraLedEx" in all .frm and .pas files
  • replace all "ueled" with "gbraExLed" in all .pas files
I don't know if this works for all (BGRAue..) components in the same way.

Regards
Jens

Please Log in or Create an account to join the conversation.

Last edit: by Jens. Reason: typo

uebutton in CT Lab version 7.70 3 months 4 days ago #17281

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 777
  • Thank you received: 76
Thanks, have fun
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

  • Page:
  • 1