Welcome, Guest
Username: Password: Remember me
Lab CT Version, news, test results, new features request and suggestions
  • Page:
  • 1
  • 2

TOPIC:

CT LAB ver 8.40 1 month 6 days ago #18433

  • Vbxler
  • Vbxler's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 66
  • Thank you received: 4
I don't know if it's a bug, maybe it's just a matter of timing of the event.
This version should work:

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 month 6 days ago #18434

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
We test your project on Win11 but without Problems

 

 
PilotLogic Core Programmer
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Matis A..

CT LAB ver 8.40 1 month 5 days ago #18436

  • skrzat
  • skrzat's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 41
  • Thank you received: 1
Matis, you tested project by Vbxler, which is working for me too.
Please test my project. Code was was working on every CT version from years, but it isn't working on 8.4.

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 5 days ago #18469

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
We release LAB CodeTyphon ver 8.40 Revision 008370

Please test and report ....
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 3 days ago #18475

  • skrzat
  • skrzat's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 41
  • Thank you received: 1

Matis, you tested project by Vbxler, which is working for me too.
Please test my project. Code was was working on every CT version from years, but it isn't working on 8.4.
Still not fixed in revision 008370 :(

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 3 days ago #18476

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
Sir what bug to fix ?

You put code in TabSheet1Show  and TabSheet2Show Procedures,
but TabSheet1 and  TabSheet2 are visible,
so, the events TabSheet1Show  and TabSheet2Show are NOT trigger. 

Put your code to TForm1.PageControl1Change


Procedure TForm1.PageControl1Change(Sender: TObject);
Begin
   Case PageControl1.ActivePageIndex Of
      0: Edit4.SetFocus;
      1: Edit2.SetFocus;
   End;
End;   


This Work OK

 
 
PilotLogic Core Programmer
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Matis A..

CT LAB ver 8.40 1 week 2 days ago #18479

  • Jan Roza
  • Jan Roza's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 161
  • Thank you received: 6
Updated to 8.40 rev. 008370 without problems on Windows 10, so far no problems found testing my projects.
Linux Mint computer is next but that will be in a week as I'm rather busy now.
Great job again guys!
Operating Systems Windows 10 (64-bit), virtual Linux Mint (64-bit) and virtual Raspberry Pi Desktop

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 2 days ago #18480

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
Thanks Sir
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 2 days ago #18481

  • skrzat
  • skrzat's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 41
  • Thank you received: 1

Put your code to TForm1.PageControl1Change
Procedure TForm1.PageControl1Change(Sender: TObject);
Begin
   Case PageControl1.ActivePageIndex Of
      0: Edit4.SetFocus;
      1: Edit2.SetFocus;
   End;
End;   


This Work OK


 

I can use PageControlChange instead of TabSheetShow, but bug is much "bigger".
I set focus on edit2 and edit4 in such way:
procedure TForm1.FormCreate(Sender: TObject);
begin
edit2.SetFocus;
edit4.SetFocus;
end;
When you change tabs, focus is changed to control which has TabOrder set to 0 (edit1 and edit3)
THIS is a bug :)
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by skrzat.

CT LAB ver 8.40 1 week 2 days ago #18482

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
No Sir  

The correct code is:

procedure TForm1.FormCreate(Sender: TObject);
begin
  edit2.SetFocus;
end;

procedure TForm1.PageControl1Change(Sender: TObject);
begin
  case PageControl1.ActivePageIndex of
    0: Edit2.SetFocus;
    1: Edit4.SetFocus;
  end;
end;  


procedure TForm1.FormCreate(Sender: TObject);
begin
  edit2.SetFocus;

  edit4.SetFocus; <<<==== this will NOT work, edit4 is NOT "visible" in the Form
end;
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

Last edit: by Matis A..

CT LAB ver 8.40 1 week 2 days ago #18483

  • skrzat
  • skrzat's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 41
  • Thank you received: 1
OK, leave only this code
procedure TForm1.FormCreate(Sender: TObject);
begin
edit2.SetFocus;
end;


When you swtich to tabsheet2 and return to tabsheet1, focus is changed to edit1.
You can add more controls and notice, that switching to tabsheet sets focus to control which has taborder=0.
It is wrong behaviour. It should set focus on control with last focus.

Like I wrote earlier, everything works fine from first version of CT until 8.30.

EDIT:
To sum up...
When changing tabsheet to another and returning to previous tabsheet, focus is lost from control which had focus,to control with taborder=0

Please Log in or Create an account to join the conversation.

Last edit: by skrzat.

CT LAB ver 8.40 1 week 20 hours ago #18484

  • Jan Roza
  • Jan Roza's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 161
  • Thank you received: 6
Installed 8.40 rev. 008370 on my Linux Mint computer as well and again no problems so far.
One thing I noticed and is annoying me: after installing a package a message window pops up with the question if I want to rebuild Codetyphon.
In Windows it shows the buttons in the message in the order Yes - No but in Linux the order of the buttons in the message window are reversed No - Yes, this is annoying if you switch Windows and Linux often.
When working in linux after a long period of Windows work I always have to watch as I automatically have the mouse pointer over the wrong button.
See the two screenshots attached.
Operating Systems Windows 10 (64-bit), virtual Linux Mint (64-bit) and virtual Raspberry Pi Desktop

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 week 9 hours ago #18485

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
Thanks Sir
We will check this and if is possible we will try to fixit.
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 5 days 3 hours ago #18489

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
We release CodeTyphon ver 8.40 Final,
after 5 months of hard work.

My respect to LAB persons for this release.
My respect to "Matis" forum Moderator, our LAB dragon man...

Thanks to students of Local University,  for their help.
Thanks to ALL forum users for their help.

Have fun...
 
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 4 days 20 hours ago #18490

  • Jan Roza
  • Jan Roza's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 161
  • Thank you received: 6
Version  8.40 final installed on both Windows 10 and Linux Mint without any problems.
Tested some of my projects on both systems and so far no problems detected.
I think after the high rate of releases in the last months it's time for all of you to take some rest, you deserve it.
Great work you've done!
Operating Systems Windows 10 (64-bit), virtual Linux Mint (64-bit) and virtual Raspberry Pi Desktop

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 4 days 19 hours ago #18491

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
Thanks My Frient
Have fun
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 3 days 2 hours ago #18495

  • Leonid
  • Leonid's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 37
  • Thank you received: 3
CT 8.40 tested using distribution Debian GNU/Linux 12 and Windows 10(VirtualBox).
Projects (gtk2, pl_RX, pl_FpSpreadsheet, lz_SQLdb(sqlite)), no problems found.
Some statistics in comparison with CT 8.3 for the same sources.
The operation of converting 615 LibreOffice Calc files into an SQLite database.
I ran the test 5 times, averaged the result and
the previous version 8.3 was 90 milliseconds faster;)

There is still a small nuance associated with the new version CT 8.4.
DBText behavior has changed. Instead of displaying real text, there is a "Memo" remark.
Unlike DBGrid, which has the "dgDisplayMemo=True" setting, for DBText the behavior cannot be changed.
A small example and an illustration based on it are attached

Best regards

Please Log in or Create an account to join the conversation.

CT LAB ver 8.40 1 day 14 hours ago #18498

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
Give us time to test and report
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2