Forum

× CodeTyphon MS Windows (XP, Vista, Win7, Win8.x and Win10) OS Development, discussions and problems

Question Issues building with qt5 widget set

  • joony3
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 8 hours ago #12920 by joony3
Issues building with qt5 widget set was created by joony3
Hello,
I've successfully built CT 6.6 small IDE under Win7 64bit (I've installed all Qt5 stuffs by myself).
Unfortunely I have found a major issue (see attached screeshot).
It looks the parent of design window is not set correctly.
Can you provide a solution/workaround for this?

Thanks,
J
Attachments:

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
5 days 7 hours ago #12921 by Sternas Stefanos
Replied by Sternas Stefanos on topic Issues building with qt5 widget set
Sir
replace
C:\codetyphon\typhon\ide\ct_emb_basics.pas
with this in the zip file
and rebuild Typhon IDE

CodeTyphon Architect and Programmer
Attachments:

Please Log in or Create an account to join the conversation.

  • joony3
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 5 hours ago #12922 by joony3
Replied by joony3 on topic Issues building with qt5 widget set
It worked!
Thanks a lot.

Another issue now :-)

I can't compile BIG ide. Script hangs at some point...
Logs attached.

Thanks,
J
Attachments:

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
5 days 5 hours ago - 5 days 5 hours ago #12923 by Sternas Stefanos
Replied by Sternas Stefanos on topic Issues building with qt5 widget set
Yes
because ALL Windows Pkgs don't work on QT5.
Medium BigIDE pkg's Level must work OK to ALL Platforms.

or
Open CTCenter and go to Tools Page
click on i386-linux-qt5 to see the pkg's for QT5 that Typhon use on i386-linux

CodeTyphon Architect and Programmer
Last edit: 5 days 5 hours ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.

  • joony3
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 days 6 hours ago #12924 by joony3
Replied by joony3 on topic Issues building with qt5 widget set
Hi,
I've been able to compile BigIDE but MINIMUM not medium.
Anyway, I've found again an issue related to Qt widgetset and Form parent not properly set.

To reproduce just create a new project --> go to designer view --> add a button --> close IDE --> save the project files when it ask.
When you restart IDE it tries to load last project --> error loading --> say "open again" --> go to designer view --> move the button --> close IDE --> save
When you restart IDE it tries to load last project --> access violation --> form parent not set.

See attached screen shot.

Thanks,
J
Attachments:

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
4 days 1 hour ago - 4 days 1 hour ago #12925 by Sternas Stefanos
Replied by Sternas Stefanos on topic Issues building with qt5 widget set
Sorry Sir
I can't give you more help

CodeTyphon Architect and Programmer
Last edit: 4 days 1 hour ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.