Forum

× Components and Libraries for Documents Development, discussions, problems and suggestions

Question PL_UTF8Tools Bug report

  • Hiroshi Yokota
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 days 18 hours ago #12841 by Hiroshi Yokota
PL_UTF8Tools Bug report was created by Hiroshi Yokota
Conversion of [No BOM] in UTF-16LE, 16BE, garbled characters occurred at the beginning of the sentence.
To be accurate, problems do not arise in case of only letters.
However, when Japanese characters enter from the beginning of the sentence, garbled characters will occur.
CT / package - I think that it will be a bug on pl_UTF8Tools.
There is no problem at all with BOM on UTF-16LE, 16BE.
There is no problem with [without BOM] [with BOM] in UTF-32LE, 32BE.
It is a problem of garbled characters in UTF-16LE, UTF-16BE to the last [without BOM].
When using PL_UTF8Tools, please keep in mind.

CT6.6


PL_UTF8Tools バグ報告

UTF-16LE, 16BE での [BOM無し] の変換は、文頭で文字化けが発生しています。
これを正確に言うと、英字のみの場合は問題は起こらない。
しかし、文頭から日本語文字が入ると、文字化けが発生してしまう。
CT/パッケージ-pl_UTF8Tools 上のバグであろうと考えております。
UTF-16LE, 16BE での [BOM有り] では全く問題はありません。
UTF-32LE, 32BE での [BOM無し] [BOM有り]でも問題はありません。
あくまでも UTF-16LE, UTF-16BE における [BOM無し] での文字化けの問題です。
PL_UTF8Tools を利用される際には、是非、念頭においてください。

CT6.6

Please Log in or Create an account to join the conversation.

More
6 days 16 hours ago - 6 days 16 hours ago #12842 by Matis A.
Replied by Matis A. on topic PL_UTF8Tools Bug report
Thanks Sir
any sample project for our LAB to test and fix ?

CodeTyphon Core Programmer
Last edit: 6 days 16 hours ago by Matis A..

Please Log in or Create an account to join the conversation.